Navegador Google

Cómo usar SUMIF en Google Sheets

Si usa regularmente Hojas de cálculo de Google y necesita sumar valores en función de ciertas condiciones en celdas específicas, debe saber cómo usar la función SUMAR.SI en Hojas de cálculo de Google.

La capacidad de agregar datos con esta función no se limita a solo dos valores. Puede sumar un rango completo. Y la condición que proporcione a la función, ya sea que se sume o no, también puede depender de varias celdas en su hoja de trabajo.

Cómo funciona la función SUMAR.SI en Hojas de cálculo de Google

SUMAR.SI es una función de hoja de cálculo simple, pero lo suficientemente flexible como para que pueda hacer cálculos creativos.

Necesita enmarcar la función de la siguiente manera:

SUMAR.SI(rango, criterio, [sum_range])

Los parámetros de esta función son:

  • Intervalo: el rango de celdas que desea usar para evaluar si sumar o no los valores.
  • Criterios: El estado de las celdas que desea evaluar.
  • rango suma: este parámetro es opcional e incluye las celdas que desea sumar. Si no incluye este parámetro, la función simplemente sumará el rango en sí.

La función parece simple, pero el hecho de que pueda sumar o comparar rangos de varias celdas proporciona mucha más flexibilidad de lo que piensa.

Un ejemplo de SUMIF con texto

Si está listo para comenzar con la función SUMAR.SI, la mejor manera es usar dos columnas en su hoja de cálculo. Una columna será para su comparación y la otra serán los valores que desea agregar.

La hoja de ejemplo anterior es del propietario de una tienda que realiza un seguimiento de las compras a lo largo del tiempo. El dueño de la tienda quiere crear columnas adicionales que resuman los precios de compra en la columna B para valores específicos en la columna A.

En este caso, el rango de comparación sería A2: A15.

El criterio sería la frase de búsqueda del elemento que se agregará. Entonces, en este caso, para sumar todas las compras de excavadoras de postes, el criterio sería el texto «Excavadora de postes».

El rango de suma sería el rango de celdas con los valores a sumar. Aqui es B2:B15.

Cuando presiona Intro, verá los valores específicos de la columna sum_range sumados, pero solo con los datos de las celdas donde la columna A coincide con los criterios que especificó.

Esta es una forma sencilla de usar la función SUMAR.SI; como una forma de extraer valores de una segunda columna en función de los elementos enumerados en la primera.

Notar: No necesita ingresar el criterio en la fórmula entre comillas dobles. En su lugar, puede escribir ese valor en una celda de la hoja e ingresar esa celda en la fórmula.

Usar operadores SUMAR.SI con texto

Aunque el ejemplo anterior busca coincidencias exactas, también puede usar operadores para especificar partes del texto que desea que coincidan. Si cambia los criterios de búsqueda, puede resumir los valores de las celdas que pueden no coincidir perfectamente, pero brindarle la respuesta que está buscando.

Usando el ejemplo anterior, si desea sumar las compras de todos los artículos excepto el taladro eléctrico, debe ingresar la fórmula <> operador.

=SUMAR.SI(A2:A15,»<>Taladro eléctrico»,B2:B15)

El operador <> le dice a la función SUMAR.SI que ignore «Taladro eléctrico» pero agregue todos los demás elementos en el rango B2:B15.

Como puede ver en el resultado a continuación, la función SUMAR.SI funciona como debería.

También puede usar los siguientes operadores al usar la función SUMAR.SI con texto:

  • ?: Busque palabras con cualquier carácter donde colocó el ?. Por ejemplo, «S?ovel» agregará cualquier cosa que comience con «S» y termine con «ovel» con cualquier letra intermedia.
  • *: busque palabras que comiencen o terminen con cualquier cosa. Por ejemplo, «*Reloj» agregará todos los elementos que sean cualquier tipo de reloj, independientemente de la marca.

Notar: Si realmente desea que la función SUMAR.SI busque un carácter como «?» o «*» en el texto (y no los use como caracteres especiales), luego prepárelos con el carácter de tilde. Por ejemplo, «~?» incluirá el «?» carácter en el texto de búsqueda.

Tenga en cuenta que la función SUMAR.SI no distingue entre mayúsculas y minúsculas. Por lo tanto, no diferencia entre mayúsculas y minúsculas cuando utiliza texto como criterio de búsqueda. Esto es útil porque si se ingresa la misma palabra con o sin mayúsculas, la función SUMAR.SI aún las reconocerá como una coincidencia y sumará correctamente los valores en la columna de valor.

Uso de operadores SUMAR.SI con números

Por supuesto, la función SUMAR.SI de Google Sheets no solo es útil para encontrar texto en columnas con valores asociados para resumir. También puede agregar rangos de números que cumplan ciertas condiciones.

Para verificar un rango de números para una condición, puede usar un conjunto de operadores de comparación.

  • >: Mayor que
  • <: Menos que
  • >=: Mayor o igual a
  • <=: Menos que o igual a

Por ejemplo, si tiene una lista de números y desea agregar los que superan el 3000, usaría el siguiente comando SUMAR.SI.

=SUMAR.SI(B2:B15, «>3000»)

Tenga en cuenta que, al igual que con los criterios de texto, no necesita escribir el número «3000» directamente en la fórmula. Puede colocar este número en una celda y usar esta referencia de celda en lugar de «3000» en la fórmula.

Así:

=SUMAR.SI(B2:B15, «>»&C2)

Una nota final antes de ver un ejemplo. También puede sumar todos los valores en un rango igual a un número específico, simplemente sin usar ningún operador de comparación.

Ejemplo SUMAR.SI con números

Veamos cómo puede usar la función SUMAR.SI en Hojas de cálculo de Google usando un operador de comparación con números.

En este ejemplo, imagina que eres un excursionista siguiendo todas las montañas que has caminado.

En la celda D2, desea sumar la elevación total de todas las montañas de más de 3000 pies que ha viajado.

Para hacer esto, deberá usar la fórmula mencionada en la sección anterior.

Apuro Entrar después de escribir la fórmula, verá los resultados en esta celda.

Como puede ver, la función SUMAR.SI en Hojas de cálculo de Google resume todas las alturas de elevación en la columna B para cualquier montaña por encima de los 3000 pies. La fórmula SUMAR.SI ignoró todos los valores por debajo de esta elevación.

Use los otros operadores condicionales enumerados en la última sección para realizar el mismo cálculo para números menores que, mayores que o iguales a, menores que o iguales a o iguales a.

Uso de operadores SUMAR.SI con fechas

También puede usar la función SUMAR.SI con fechas. Nuevamente, se aplican los mismos operadores de comparación enumerados anteriormente, por lo que no tiene que preocuparse por aprender otros nuevos.

Sin embargo, para que la función funcione, las fechas primero deben formatearse correctamente en Hojas de cálculo de Google.

Puede escribir manualmente la fecha en la función o escribirla en una celda y hacer referencia a ella en la fórmula. El formato para esto es:

=SUMAR.SI(B2:B15, «>4/10/2019», C2:C15)

Como funciona :

  1. SUMIF verificará el rango B2:B15 para todas las fechas posteriores al 4/10/2019.
  2. Si es verdadero, SUMAR.SI sumará todas las celdas de C2:C15 en la misma fila donde esta comparación es verdadera.
  3. El total resultante se mostrará en la celda donde escribió la fórmula.

Si tiene una celda donde la fecha no tiene este formato, puede usar la función FECHA para reformatear la fecha correctamente. Por ejemplo, si tiene tres celdas (D2, D3 y D4) que contienen el año, el mes y el día, puede usar la siguiente fórmula.

Por ejemplo:

=SUMAR.SI(B2:B15, «>»&FECHA(D2, D3, D4), C2:C15)

Si tiene una hoja de cálculo que tiene las últimas compras en la parte superior de la hoja, simplemente puede usar la función HOY para resumir las compras de hoy e ignorar el resto.

=SUMAR.SI(B2:B15, HOY())

SUMIF en Google Sheets es simple pero versátil

Como puede ver, la fórmula SUMIF en Google Sheets no toma mucho tiempo para aprender. Pero las diferentes formas en que puede usarlo lo hacen tan versátil.

Si usa muchas hojas de trabajo en las que necesita sumar valores según las condiciones del texto o los números de otras celdas, debe estar familiarizado con la función SUMAR.SI.

Republica GEEK

Esta pagina es para ti, seremos tu apoyo en esta situación, quiero que sepas que no es un problema, es un hobby y como tu nosotros también lo ejercemos. Diseñada con la única intención de darte la información que no encuentras en otro lado, nos encargamos de montar la información que sabemos te importa. Así que, acompáñanos a llegar mas lejos...

Publicaciones relacionadas

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Botón volver arriba